API key provided does not have write permissions - WooCommerce

API key provided does not have write permissions - WooCommerce

Problem

CartRover displays the following error message when trying to communicate with WooCommerce:

Could not confirm order:

The API key provided does not have write permissions

Solution

  1. In the left pane of the WooCommerce Dashboard hover over "WooCommerce" and click on Settings
  2. Click on the API tab
  3. Click on Keys/Apps and then click on the existing API Key
  4. Set the permissions to "Read/Write" and save changes. 


    • Related Articles

    • Fix WooCommerce Permissions

      In the left pane of the WooCommerce Dashboard hover over "WooCommerce" and click on Settings Click on the API tab Click on Keys/Apps and then click on the existing API Key Set the permissions to "Read/Write" and save changes. 
    • Error adding notes to order - WooCommerce

      Problem After orders ship, CartRover is raising the following alert: Error adding notes to order Could not add tracking note to order: XXXX You do not have permission to create order notes Solution In the left pane of the WooCommerce Dashboard hover ...
    • Setting Up WooCommerce

      Integration Specs: Supported functions: Order Download Shipment Confirmation Inventory Sync Required Parameters Store URL URL Format: https://<store_url>/ Consumer Key Consumer Secret The minimum supported version of WooCommerce is 2.2.0 Step-by-step ...
    • Cannot connect to WooCommerce site

      Problem CartRover cannot connect to WooCommerce site. Solution Make sure you have WooCommerce version 3.0.0 or above. Having the latest version can help as well. This can be found at WooCommerce > System Status > WC Version Upgrade Instructions Try ...
    • Sorry, you are not allowed to create resources - WooCommerce

      Problem CartRover is raising the following alert when trying to mark your orders as shipped: Subject: Error adding tracking to Tracking Extension Message: Could not add tracking data to order: XXXXXX woocommerce_rest_cannot_create: Sorry, you are not ...